[SOLVED] BIG ISSUE with Terra Bridge


I have just used the Terra Bridge to send my LUNA to my Binance Smart Chain Metamask account. When including the address I copied and pasted my Metamask account and I have not received the funds. When I see the details it says that my funds have been transferred to this account:



But not to my Metamask account. It was quite a lot of LUNAS (+28). Instead, what I see is that the address I wanted to send the funds to appear to be the MEMO of the transaction

Please, I would really appreciate your support on this

Thanks a lot

This is the HASH of the transaction 1BC16487F08D88A3325A94FEDFC7C2BE20FDF95B5B7EAB1D3615F161AEEB8F4E

Thanks in advance for your support

Looks like you have already got your LUNA on BSC.

Should change the title to [Resolved] or something.

Terra Bridge can’t send fund directly to your BSC account. That’s why your BSC address appears as memo.

Thanks for your swift reply Tanwa_Sabai, I really appreciate it. I cannot see the LUNAS I have transferred to my Metamask account. I just see my BNB balance. What am I doing wrong? When I try to add the token with the contract id it tells me that the contract address is wrong

Sorry if the questions I am asking are too obvious and thanks again for your kind support

I have managed to include the LUNA token within my BSC Metamask wallet but I am still seeing the balance at zero… Do you know why? Thanks a lot for your support

SOLVED! I was adding the LUNA token but not the wrapped LUNA one. Don’t really know the difference but my funds are there :slight_smile:

Once again, thanks a lot for your support!!


Yeah. Go go. Luna everywhere.

Bro,kindly look into it

If I find I have a problem. I may come looking for you. That is great support for someone who needed help. Good for you.

Hi, I had a similar problem, I transfered with terra bridge some LUNA to BSC and my wallet adresse appears in the memo of the transaction. I can’t find the Lunas even with Metamask and Smart Chain Wallet. It reconizes the contract but the funds aren’t there. Maybe this can help, we can see the transfer but amount is zero ¿?

I also have similar problem. I tried sending 510 ust from terra to bsc. The message from the bridge say failed. But my ust was gone from my terra wallet. However, when I check the transaction it say success:

But my ust was not deposited into my metamask.

Thank you in advance.

I was wandering if anyone could help me with a similar problem. I sent 300 aUST from my Terra station wallet to my MetaMask wallet via the Terra bridge. (Bridged to eth). I did the correct address which is the UST token I set up in my MetaMask on the eth mainet. The ust has left my Terra wallet but my MetaMask balance is 0

Here is the hash

The MEMO shows the correct address


But it’s saying it’s sent to a Terra address


I’m so confused thanks in advance!

The same thing happened to me 2 days ago trying to send aUST to Metamask address

Transaction says success but it is showing sent to the same Terra address you have which I did not enter:

The MEMO shows my wallet address and the aUST is gone from my Terra wallet

Transaction hash is:

Try adding this contract address in your Metamask wallet


I went on Terrabridge and transferred the money back to my Terra wallet

Initially it said it went to a null address and listed the transaction as a burn on etherscan but it just hit my wallet now. I’m relieved but very confused

Hi, I tried to cross-chain 6 LUNA from my wallet ( terra13qyqjlh06x0v2tjwxl2q600k05m03rzwdr679a) to my other BSC wallet (0xaf1d2479a85d9d146d86285fb29b56f4bd9f092d) , but the system never sent them to the destination. The 6 LUNA are in the adress: terra1g6llg3zed35nd3mh9zx6n64tfw3z67w2c48tn2

In the transaction my Address BSC wallet appears as MEMO

Transaction Details:

Tx Hash: 6AADCE95FDC45F9B8EE1DED54E74E54F3C0C3D3394DC52E5BA5B77989C2F91E9

I greatly appreciate your collaboration.

1 Like

Hello, I’ve had the exact same thing happen to me today. Im on smart chain but I can’t seem to find a contract address for the wrapped luna, only for the ethereum network.
What did you use as contract address?


I have the same problem, could you solve it? thanks


I used terra bridge to transfer UST from Terra to my Metamask (Binance smart chain). The transaction finished ok but I cannot see my UST on me Metamast wallet.
Do you know what happened?

This is the transaction


1 Like

If anyone is still having an issue with Terra to Metamask BSC bridge try this….

I transferred UST from Terra to Metamask BSC and it wasn’t showing up. Went back and forth and made sure the correct token address was entered into my Metamask and still nothing.

Next, I made another small transfer of UST from my Terra wallet to my Metamask BSC. When I got to the page below (it’s the page that says complete with a large blue check mark), I clicked on ‘Add UST to Metamask’ and my previous UST showed up in my wallet.

Weird hack but it worked. Hopefully this helps someone out there. Worst feeling when your crypto goes missing….:angry::rage::face_with_symbols_over_mouth::sob: