Wallet issues

Good day

My terra station doesn’t generate my initial address of wallet and even I recover my wallet several times with 24 mnemonic phrase each time it give me a different address but never my initial wallt where my funds are stacked.
Also it unblock wallet after entering 12 words and sometimes with a different address.

Try to solve it by keplr nothing change, same address issue.Also bu cosmostation
Several times installed & remove terra station on desktop and mobile but nothing changes.
No possible to get my initial address.I manuanlly addes colombus-5 network but impossible to generate my initial wallet address.
Tried with different HD derivation path no solution.
My passphrase and password are correct and printed on a paper.

My initial wallet address where my funds are stacked is:


Contacted support of Luna team by telegram nobody can help.And a lot scammer on telegram.
Discord link doesn’t work.
Do you know how I can get my funds?
Is there any way to recover my intial addrass?
Thanks for your return.
Best regards.

1 Like

hey man,

first - there is no luna support and all dms are scams. there are community members that can help in official luna chats. don’t give anybody your seed phrase and don’t enter it on any websites.

for your issue - usually one of the following helps:

  • make sure you are typing in your seed phrase correctly
  • use same wallet name as your original wallet
  • recover wallet using Keplr or XDefi wallets

seems you tried most of it already?
90% of the cases it is the incorrect seed phrase (you can check possible words here).
if your seed phrase had a wrong word in it - keplr would tell you that.
is there a possibility of this seed phrase being from another wallet?
another thing you can try is to use brave browser and try and recover your wallet there - in terra station extension and keplr wallets.

if none of this helps only option left is to use a small js code where you’d specify your seed phrase and try different derivation paths - but that requires coding skills. if you manage to do it - you could export the private key and import it to terra station.

here is an example of how to access wallet programmatically using terra.js. it doesn’t let you choose derivation path, though. for that you’ll need to use cosmjs

Hi Alagiz

Thanks for your feedback. A scammer already wrote me for asking my seed. i signaled him with a red flag.
In reply , I’m sure my seed phrase is correct, printed on A4 paper and I copy excayly the same.
wallet name is the same also.
Tried to recover it by brave extension of keplr , xdefi & cosmostation also with other wallets.
But never got my initial wallet address
Keplr accepts my seedphrase , ther is nothong wrong here.
Seedphrase is coming from my first wallet, but terrastation creaate new address when in do recover with same wallet name and seed phrase.
For the last solution which you propose, i do not have programmation skillls but can try to do someting following to your link.
During my recovery tentatives, I tried sevrel times with differnt index ( derivation path) but never successfull.
Thanks for your return.

HI Alagiz
I took a look js pages but a lot information.
Is there any way for you please to send me an example, I’ll put my seeds into and try to resolve from my side.
Thanks for your help man.
Best regards.

Merhaba cüzdan cekim sorunlarına ek olarak trust wallet cüzdanından 10 günden fazladır lunc cekim yapılamıyor bu konuda bir çalışma varmi acaba?

Hello, in addition to the wallet withdrawal problems, lunc withdrawal cannot be made from the trust wallet wallet for more than 10 days, is there a study on this issue?

it is very weird that none of the mentioned approaches worked, usually it means that this seed phrase is from another wallet.

but here is a small node.js example of accessing a wallet programmatically - it should print wallet address in the console. in case it prints the correct address - you’ll need to write the code to undelegate/transfer the funds, but that’s for later and only if you get access to your wallet.

i can’t give you a node.js course, but you can try the following:

  • install latest version of node on your pc
  • create a folder named app
  • create 2 files in this folder - package.json and app.js (based on the code below)
  • run npm install in terminal in this folder
  • specify your mnemonic in app.js
  • run npm start in terminal in this folder
  • it should print wallet address in the terminal(console)


  "name": "app",
  "version": "1.0.0",
  "description": "",
  "main": "app.js",
  "scripts": {
    "start": "node app.js"
  "keywords": [],
  "author": "",
  "type": "module",
  "license": "ISC",
  "dependencies": {
    "@cosmjs/crypto": "^0.28.2",
    "@cosmjs/proto-signing": "^0.28.0",
    "@cosmjs/stargate": "^0.28.0",
    "cosmjs-types": "^0.4.1"


import {
} from "@cosmjs/proto-signing";

import {
} from "@cosmjs/stargate";

import tx from "cosmjs-types/cosmos/tx/v1beta1/tx.js";
import {stringToPath} from "@cosmjs/crypto";

const mnemonic = "mnemonic-goes-here";
const path = stringToPath("m/44'/330'/0'/0/0"); // derivation path can be specified here, 330 is coin_type terra station uses. you could also try 118 instead of 330 - cosmos coin_type
const wallet = await DirectSecp256k1HdWallet.fromMnemonic(mnemonic, {
  prefix: "terra", hdPaths: [path]

console.log(await wallet.getAccounts());

it’s hard to understand what the problem is, but sounds like something you should ask trust wallet perhaps. also if you have a question - create a separate thread, don’t ask in this one.

Hi man

It seems terra node works on mac and linux. I do not have boths. I’m running on windows.
Honestly not sure I’l have enough time to resolve this and I’m not an expert in computing.
Could you please write me in private , to my mail address.
It will be better if we can discuss in private channel.
Thanks a lot.


i meant node.js, not terra node, and it can be installed on windows also.
you can send me a private message, but i will tell you the same thing there)

Hi man

Thanks a lot for your help.
Followed your instructions after runnibg both commands in terminal, tried with path 330 & 118 two differnts address have been printed.
But no one is corresponding to my initial wallet, wher my founds are.
How we can resolve please?
See below two images ( screen shots)

hey @viki1,

just to clarify - you are using 24 words for seed phrase, right?
if yes - i’d say only 2 options are possible:

  • this seed phrase is from another wallet - you said keplr was able to recover some wallet with this seed phrase, which means this seed phrase is valid and from a real wallet. but from what you are saying it very much seems like it is a seed phrase from another wallet. are you absolutely 100% sure that you didn’t mix it up with some other seed phrase?
  • maybe you somehow changed index of the wallet and you could try to change those to see if it makes a difference (you can refer to How to Set a Custom Derivation Path for explanation - address_index is something you could try changing, so it would be for example m/44’/330’/0’/0/1 or m/44’/118’/0’/0/1)

in the second option there are infinite amount of combinations, but i’d only try a few.

Lunc is being sent from my terra wallet to terra1a2t22y8hxqqqvksxvtam9ymukgze0e3hhuunly5 without my request. please help how can i get it back

terra16lhc053ygqm3t2sklhku6v3a384vv3cf39t4q0 552.000 lunches were sent from my terra wallet to terra1a2t22y8hxqqvksxvtam9ymukgze0e3hhuunly5. please help how can i get it back. How to send without using password.

it means your wallet has been compromised (you probably inserted your seed phrase on some fake website or into a fake terra station popup).
there no way to get the funds back once they left your wallet.

what could be the place i marked thisistest


this is not a place, it is just a memo of the transaction. scammers are testing some of their scripts it seems