Can not swap UST to LUNC in Terra Wallet

Is there an issue with the Classic Terra Wallet swap facility? When I try to swap UST to Luna I get the following error message

TypeError: First argument must be a string, Buffer, ArrayBuffer, Array, or array-like object.


Yes there are some issues being looked into by devs. Try refreshing, clearing cache, if that doesn’t work you will probably need to wait for the terra station update patch



Still costing me gas, though. Tried gas in LUNC and UST.

1 Like

I cant send token on Terra classic network and i cant swap. Guys evetybody taken this error ???

Yesterday, I had 13.61 new lunas (Terra) that were impossible to withdraw from staking rewards in the Luna Classic network (validator:
However, on the mainnet, I didn’t see receive any lunas for the airdrop.
Today it changed and I still have 13,61 lunas, but 13,61 LUNC, not Terras. However, it still has the value of the new luna (Terra). It’s still impossible to withdraw.
I can’t withdraw my lunas because as a fee it is written : 0
And I have the following message below: Insufficient balance to pay transaction fee
When I try to withdraw I get the following message: Error, fee is not estimated.
And I have some lunas to pay the fees so that’s not the problem. The problem’s that it’s impossible to withdraw and that I didn’t get any airdrop on Terra 2.0 even if I had lunas on the Terra Station.

Please see the pictures on the link: https://

Can someone help me?
Thank you so much!

You don’t have enough old Luna in your wallet to perform any transactions.

1 Like

Thank you.
But if I had lunas that I bought before the attack why am I not getting any airdrop?
Address : terra1y27ymrs9hpmrsygmvajdtj5acz9e88du624wjf

1 Like

What is your address?

My address is :


This wallet has only 0.6 $LUNC, it is not eligible for an airdrop.

Why twitter accounts does not say nothing about this things? Trustwallet is sending tweets every error.
Terra Station has no twitter and support things. I meant they should have annoucement account. How can we follow the process sir ?

1 Like

Same here, though different message -
“[DecimalError] Invalid argument: undefined”.

Does anyone know whether it’s a bug and/or if/when it may be fixed ?

@Dluna - did you manage to swap eventually ? Tnx

The swap function still doesn’t work. Any idea what’s happening? Did anyone manage to find a solution?