): “Fee estimation failed” error: [DecimalError] Invalid argument: undefined

I get an error message when trying to withdraw UST(C) from Terra Station (classic network):
“Fee estimation failed” error: [DecimalError] Invalid argument: undefined

The same error appears when trying to swap USTC to LUNC.

Any hint on how to solve this?


There are some issues with Terra station atm. You will be able to do the operations after it will be resolved.


Oh thats the answer ! Thank you man Thank you ! Finally someone said something. Thank you.

can we follow from somwhere ?

You will be updated through the Terra twitter account, but please make sure you are following the correct one as there are a lot of scams going on.

1 Like

I’m also getting this error when I try to either send USTC from Terra Station. When I try to type in my password, I get that message. At first I thought it was due to insufficient LUNC balance, but that’s not the issue.


I’ve found a solution to this error message in the Terra Station wallet (desktop app).

I followed the suggestion posted by @alagiz in another Agora thread “I cant send any token from Classic”. You can check his reply there.

These were my steps:

  1. Add Terra Station Wallet extension for Chrome and import your wallet.

  2. Open the web site pointed out by @alagiz (station dot terra dot money).

  3. Connect your wallet to this web site when prompted in the pop-up window.

  4. Send USTC/LUNC from this website wallet to your exchange.

It worked for me. Hopefully it will help somebody else too, until devs fix this someday…


I have the same problem. So which is the correct Twitter account? Thank you.

Twitter.com/terra_money, but be very careful reading replies to their tweets as there a tonne of scammers pretending to be support there.

Hi, unfortunately the solution suggested didn’t work for me. I already used the chrome extension in combination with my Ledger. Still cannot either swap nor send anything on classic. Do you know if anyone is working on this problem?? So frustrating not being able to reach an active developer…

A workaround is that you bridge the ust or lunc to for example bsc or eth through the classic terra wormhole. Once they’re on another chain you can do whatever you want with them.


This is what i get when try to swap. It has been a few days. I have tried all the methods that others shared. Not working for me.

I may have just figured it out accidentally. I also had the same issue where the Chrome extension wasn’t working. I had the Terra Station desktop app and it was giving me that decimal error message. Even on my Chrome extension, it was giving that error message as well.

What I did: clear History on Chrome, uninstall Terra Station app (remembering to keep your 24-word mnemonic handy in case you need to recover your wallet), go back to the Chrome Extension and connect (I clicked Terra Station Wallet). I didn’t have to recover my wallet since I probably already set up the Chrome extension a while ago, but if you just downloaded the extension, then you’ll probably need to Recover Wallet and type in your 24-word mnemonic.

Once I’m on the Chrome extension after uninstalling the desktop app, I no longer see the decimal error message. I’ve been able to redelegate my stake, withdraw my rewards, and send USTC to an exchange.


Figured it out.

On the web app, top right corner, click on your address and Disconnect.

Now top right corner click on Connect. DO NOT click on Access with ledger. Click on Terra Station Wallet. UGH. This dumb small step has wasted me so much time. You’ll then connect to the Classic web app, not the Terra 2.0 version.

Keep in mind I was already signed in to the Chrome extension in Classic mode with my Ledger that’s why it automatically connected to the web app even though my Ledger was locked.

1 Like

Good Evening Tammet can you please elaborate a little bit more about this? Thanks

Bro you are the man! Took me a few tries but it worked! Great job and thanks!

Hi , I have error “ fee is not estimated” when I try to withdrawal reward . I have tried to connect wallet to web , it doesn’t help

means you don’t have any LUNC to pay for the fees. it doesn’t estimate it if you don’t have any liquid coins.

I noticed there are some bugs in the Terra Station (Classic Network) on the gas fee. On several occasions, and also currently now, there is a discrepancy in the gas fee being charged by Terra Station (for Classic Network) when we stake our LUNC and delegate to a validator. Terra Station Wallet Web App shows the fee to be 10 LUNC, but the hardware Ledger LCD panel shows the ACTUAL fee is 1160 LUNC being charged. The actual fee was 1160 LUNC charged which is more than 116x the correct fee of 10 LUNC that was displayed by the Terra Station Wallet web app. Hope that this bug in the Terra Station could be resolved such that the actual fee charged is as per what Terra Station displayed and not charge more. Compared to Rebel Station which the actual fee charged matches the fee displayed. Could the developers of Terra Station resolve this bug?