"Data is invalid : JSON. Too many tokens" When withdrawing staking rewards in UST

Hi, there is an option in terra station to withdraw staking rewards as one token. However when I try to use this option, to withdraw my rewards as UST, after submitting the transaction I’m always met with the error “Data is invalid : JSON. Too many tokens”, I do use a ledger if that’s relevant to this issue at all. Is this a known issue and is it being fixed soon? I would really love to use this feature for tax purposes.

1 Like

@admins, @Gobson is a scammer

Hello, I have the same issue.

I can’t withdraw my staking rewards with terra station wallet. It doesn’t work with ledger, I get this two messages: “Error: Transport has not been defined” or “Data is invalid : JSON. Too many tokens”. I tried to quit and re-open the luna app on ledger but it never works. I use ledger Nano S. These are the errors:


Hmm I’m curious if anyone with a ledger X has been able to use this “withdraw as xyz” feature at all, to tell us if its just an issue with the ledger S or ledger in general. I have tried googling around but it hasn’t helped very much. I only found a few reddit posts about NFTs on randomearth with the same error message, without any helpful responses.

I get the same error when trying to use “withdraw as …” … works fine with my ledger if I do not set that option

A bit late, but a Google search led me here and I’m adding for any others who find their way here the same.

I was able to claim staking rewards converted to Luna using a Ledger Nano X whereas I could not using a Ledger Nano S (“too many tokens” error). This appears to be a limitation of the Nano S.

However, for anybody considering this, unless you have substantial staking rewards, you will be better off claiming all the tokens and just swapping your UST for Luna. Many small amounts will convert to ~0 Luna which means you’re paying additional transaction fees for no benefit.