LUNC Staking rewards stopped?

Did staking rewards for Luna Classic stop? I noticed that mine haven’t changed for a few days.

no, they didn’t stop, maybe validator you delegated to is not in the active set anymore (or offline or something)

I see. But I can’t stake to another validator, is that right? So basically, I can’t do anything for now?

Actually, I’m staked to, and it looks like they’re still active. Is it an issue with the Terra Station display?

1 Like

could be a display issue, you can check what this link returns once you replace walletAddress with your address -


fyi to convert uluna to luna it needs to be divided by a million

and you can redelegate by the way

Thanks for the link. I checked it and it matches my Terra Station rewards. This amount hasn’t changed since this morning, and I believe it’s been the same the last few days. Maybe my validator went offline or something but that’s not being reflected.

By the way, you said you can redelegate? I didn’t know that. I thought there was no more staking allowed. I’ve been staked to the same validator pre-depeg. If I unstake from them, I can re-stake to another validator?

you won’t be able to delegate again if you undelegate (unless things change after 21 days undelegation period), but redelegation is possible right now.

to do that you need to go to Stake section, choose new validator you want to redelegate to, click Redelegate, choose your delegated lunc as source, specify the amount and broadcast the transaction.

here is an example -

Thanks, I appreciate it!

1 Like

no problem! keep in mind that you can only redelegate once per 21 days, though.

Actually, I tried it just now and I get that decimal error message when I try to redelegate. Is there a workaround to this to redelegate outside of the Terra Station?

I tried going to, and once I connect and go to Stake, I see everyone has 0% voting power. Do you currently have any Luna Classic, and if so, are you getting staking rewards still? I don’t think it’s just me, but I’m not sure.

yeah, there is a workaround that works for some people - connecting to with the web extension and executing commands like send / withdraw staking rewards / redelegate from there, you can try and see if it works for you. the decimal error is known to the devs, so it will be fixed at some point (hopefully soon).

for voting power though - i can see the values on, maybe you just need to sort it on voting power? i stake with BlockNgine :shield: Slash Protected and i am still getting staking rewards.

Thanks, I appreciate it. Yeah, something’s wrong then. This is what I see when I go to connect to my wallet:

When I am not connected, then I see voting power (though not the same numbers you see, maybe because I only see Terra 2.0 when I’m not connected). When I connect, I see everyone has 0% voting power.

that’s fairly weird, i couldn’t reproduce it with my setup. are you using chrome?
tried clearing cache / refreshing the page?

does this link show you non-zero voting power?

This is what I see:

Is that link you sent for classic or for Terra 2.0? I’m on Chrome.

On Firefox, when I connect via read-only by typing in my wallet address, when I go to stake and look for my validator, I see the numbers I had seen last week:

When I search for Block NGine, I see:

When I go to Chrome and connect directly through Terra Station Wallet, I see:

alright, well, the api call looks correct so it is some sort of display issue.
it is for classic network, as your goal was to redelegate on classic network.
meaning before going to you’d need to set network to classic in terra station web extension (or refresh the page once you did that).

what do you mean by connecting directly through terra station wallet? terra station web extension or something else?

Thanks for the clarification.

I may have fixed it by uninstalling Terra Station from my desktop. I thought it was strange that using Firefox’s read-only seemed to give the right numbers but Chrome was not giving the right numbers when I tried to connect in the following way:

  1. Go to
  2. Click Connect in the upper-right corner
  3. Click Terra Station Wallet

When I did that, it was giving me 0% voting power for everyone when I clicked Stake.

Then I thought maybe it was trying to connect with the app on my desktop and the app is bugged, so I just uninstalled the app on my desktop. I cleared my Chrome history and went back to and followed the same steps above.

Now when I go to stake (for Terra Classic), I see this:

Now the voting power numbers look right.

But at the same time though, when I clicked Withdraw Rewards and check the numbers over the last few minutes, they haven’t changed (and they should have).

However, I could withdraw the rewards fine now without the decimal error issue now that the chrome extension is not connected to the desktop app. I can probably withdraw to an exchange without that error anymore.

If someone has the decimal error issue on their app, you can tell them to try to uninstall the terra station wallet (reminding them that they’ll need their 24-word mnemonic for recovery) and use the chrome extension after uninstalling their desktop app.

1 Like

great, thanks for the info!