Error message while attempting to Redelegate

I am attempting to redelegate my staked luna to a smaller validator but keep getting an error message. When I click on the Delegate button the delegate window pops up. I choose the validator I am currently delegating to as the source and enter the amount of luna I currently have delegated to them. When I click next the confirm window appears with the following message:

“Redelegation to the same validator will be prohibited for 21 days.
Please make sure you input the right amount of luna to delegate.”

Before I can enter my password the window disappears and an error message appears in its place saying:

"Oops! Something went wrong

redelegation to this validator already in progress; first
redelegation to this validator must complete before next
redelegation: failed to execute message; message index: 0:
failed to simulate tx"

This error appeared the first time I tried this so there is no redelegation in progress. I have enough luna in my wallet to cover the delegation fee and I’ve tried entering a smaller amount of luna than the max I have delegated. I’ve logged out, quit and restarted Terra Station. I’ve tried delegating to a different validator with the same result.

I’ve only been delegating to the current validator for a few days. Could this be a problem? Is there a limit to how soon you can redelegate?

Does anyone have any ideas?



I have the same problem

1 Like

You can only redelegate once in 21 days.