Governance Section Not Showing New Proposals In Voting Section

Governance Section Not Showing New Proposals In Voting Section (with the exception of proposals 1188 and 1164 as of 12:49pm UTC)

Steps To Reproduce Issue
Goto Terra Station > Governance > Voting

Expected Result
It should show proposal 1597 ( )

Actual Result
It does not currently show proposal 1597

Visual Proof (screenshots, videos, text)


Thank you :slight_smile:

1 Like

hey, so you mean when you go to - it doesn’t show you anything? or is the problem on desktop app?

have you tried closing/opening the page/app again?

I have tried both the desktop app (which is where the screenshot is from), and the website ( ). I will go ahead and post a picture of the website as well.

Image of website:

Thank you so much for your help :slight_smile:

Also, I did try closing and reopening both the desktop application as well as the website, and refreshing, but it did not resolve the problem for either the desktop application or the website.

1 Like

There’s another post that few other member said they removed them? Because they didn’t want the burn proposal to pass. So maybe they did something to keep new Luna holders from voting. Speculation on my part who knows.

alright, i can see that it is a new feature introduced a couple of hours ago - whitelisting of the proposals displayed in “Voting” section.

as there are a ton of spam proposals, so it is impossible to understand what is an actual proposal and what is not.

Since my proposal has already met the deposit of 50 LUNA, it does not appear in the Deposit section. How would I go about having the proposal whitelisted? Is there a process for this?

Thank you again for your help :slight_smile:

ah, yes, you are right, it is in Voting category, but it is visually filtered out as it is not a part of the whitelist.

i don’t know the procedure yet as the feature was introduced a couple of hours ago, once i know something about it - i’ll let you know.

So where is the Terra Ecosystem Revival Plan t/terra-ecosystem-revival-plan-2/18498 ?
Why isn’t it white listed in the Voting section ?


it should be up today, it doesn’t exist on-chain yet

1 Like

Hi @alagiz ,

Was your response for Mr.WellOff (and Terra Ecosystem Revival Plan t/terra-ecosystem-revival-plan-2/18498) or for myself and Proposal 1597 (or both of us)?

Just wanted to make sure.

I really appreciate all your help :slight_smile:

Can you whitelist proposal 1273

People were voting on it

Hi @alagiz hope you are fine. Could you whitelist this one. Thank you

@alagiz our prposal was whitelisted now its hidden ajaoon

1 Like

please @alagiz relist proposal 1273 again. thank you

Time is being wasted just like votes because it is still not showing for a few hours now. PLEASE RELIST PROPOSAL 1273! @alagiz @AtoZ

We’re having the same problem with Prop 1691 not showing up or votable by the community. The proposal is fully funded but remains invisible. A direct link to the proposal can be accessed from the website but when submitting a vote the submission just hangs forever. The Terra Station no longer shows the proposal anywhere after a full deposit was made. Can we have this fixed?

Hi @alagiz ,

Proposal 1597 is still not showing as whitelisted in Terra Station > Governance > Voting on the front page or on the desktop Terra Station (in the voting tab). Can you please help in getting it whitelisted (it has been a day now, and I only have 6 more days of voting).

Thank you so much for your help - I really appreciate it :slight_smile:

hey, the proposals mentioned above were whitelisted, and there is a whitelisting procedure published here