Unable to recover terra station wallet with seed phrase/mnemonic

I tried to recover terra station wallet on desktop with seed phrases/mnemonic but unsuccessful. Have tried at least 5 times and each time, a brand new wallet is created rather than recovering my original wallet. I entered all required info correctly: wallet name, password, and seed phrase/mnemonic, double and triple checked spelling of everything too. I was able to recover on mobile version but would ideally like to use desktop version. Has this happened to anyone and is there a solution for desktop chrome extension? Please help.

U might made a mistake with the backup of the passphrase


Are you still able to recover on mobile? If so you may recover on mobile and then export the wallet.



Yes, I was able to recover on mobile. Thank you, I will try exporting and will report back.


Why have it easier on a phone, the same variables can be passed on a comp, is this an error or a feature lol

Exporting to get private key worked and was able to recover wallet on chrome extension. Thanks for the help.

1 Like