Tried to transfer funds through wormhole to eth and it never arrived

I tried to transfer funds through wormhole to eth and it never arrived. Went to portal bridge and it says it’s already ‘reedemed’.

Thank you, the tx id is:

Appreciate your help in figuring out what happened to it as funds never arrived.

1 Like

I have the same issue with a transaction made 4 days ago:

Previously I had bridged UST on eth to terra and they appeared on metamask with the contract 0xa47c8bf37f92aBed4A126BDA807A7b7498661acD, so unless the contract for UST on eth is not this one anymore, I haven’t received anything.

hey @mk135 for your case it is wormhole ust.
you received it 2 days ago, although the fee was ~23 ust because of price fluctuations Ethereum Transaction Hash (Txhash) Details | Etherscan.
so you should be able to see it once you add 0xa693b19d2931d498c5b318df961919bb4aee87a5 contract address to your metamask.


no, wait a sec, it is the same transaction id as @lunarekt specified?

well, the answer i have above is for transaction id 39C483805B5DFB09010775FCCC79DB30162D3BD0AE6D20698ACF4709C15F394B, let me know if some of you still have issues.

ha yes messed up the tx id, but it works, it was indeed the contract address that I needed, thank you

1 Like

ok, so this is not the same contract address anymore and I just sent a few thousands to Coinbase that won’t recognize it :cry:

You have to redeem your tokens here.

Enter the source chain (Terra) and transaction ID then it should say “eligible for relay”
Select the relayer and press relay to get the tokens released on the target chain.

Yes that seems to be it. Thank you very much! I didn’t realize that it’s a different UST (Wormhole UST).
Didn’t realize it’s a different version than the regular wrapped one.

1 Like

@mc_ust @alagiz I’m having a very similar issue and have tried to reach out to you on telegram - you mentioned that I should reach you here…can you please help me?

For reference, I was trying to redeem my UST through Wormhole but Its not working. I reached out to Wormhole support and they said it was because Anchor’s smart contract is slow right now and experiencing delays. Is there someone who could walk me through how to get my aUST/UST into my Terra Station Wallet (or Metamask)?

Here’s the TX Hash: 660A17E61C149C1B1C3F650D3D6B3C394A7C358E1286FE7141FACF825845FD32

Here’s a video of me trying it and it not working: loom[dot]com

What should I do?

Try to redeem UST again now.

1 Like

Just to confirm you have send UST from Metamask Erc20 to Terra Station through wormhole?

Hi how long does it normally take for a relayer to get the tokens released once we pressed relay?

I tried again but it didn’t work…

Did you see my walkthrough video in the previous post @mayankgrover733 ?

Please provide your wallet address on Avalanche network.

should be instant and there is a button to “add the token ID” to your metamask as it will not be wrapped UST but wormhole UST which is a different token ID

Hi, I was having an issue with WLUNA. I have my token on metamask then transferred it to kucoin via classic-bridge using shuttle. It didn’t showed up on kucoin and I don’t know how to trace the transaction on the terra bridge. Can anyone help me on this? Below is the transaction id from eth scan.


1 Like

Sorry buddy, but it’s lost now. You can’t use bridge to transfer to an exchange, otherwise you will loose it.

I suppose its only sitting on the kucoin wallet since it is shared by its users. If there’s a way to track the transaction on terra bridge then it would help. I just followed this guy’s tutorial and video is still up there and I wonder what the intention of misleading users to do his video.

I withdrawal the Terra Classic into the Tiera wallet and it didn’t arrive, what’s the problem


1 Like