Impossible to interact with Terra station wallet

I have a pending issue since many months: I see my LUNA coins on my Terra station wallet, but as soon as I try to interact with my wallet, it shows this error message “invalid kex string”. I tried everything, even to download my wallet on a new computer with my private key; The wallet is back, shows all my assets, but as soon as I try to interact, I get this message again “impossible to broadcast transaction - invalid hex string”

Can anyone help ?

1 Like

hey, you’ll need to recover wallet with your seed phrase to resolve this issue.

1 Like

have the same issue the solution offered not helpful since I have private key only and no one seems to know what is causing this error

the solution is helpful because it is the only solution. the error is caused by the fact that the private key you have is corrupted, so you can’t do anything with it.


Dear Alagiz

Thank you so much for your help ! So simple, and it all worked :slight_smile:

I’m super happy, I even was able to unlock my coins blocked on Anchor protocol. Ok I lost about 90% of the value of my coins (UST and Luna), but that’s another story…

Thanks again man, community cle

1 Like