Osmosis users - can't find airdrop? Check here

Hi everyone,

I’m trying to collate some information for Osmosis users’ airdrops. If you are struggling to find your airdrop, first read through the following and try the various methods. If you are still stuck, at the end I will collect some details from you.

First of all, Keplr and Terra Station wallets can have two, even three, different terra___ addresses due to the Cosmos and Terra derivation paths. In the simplest case, your airdrop will be on the terra address you see in your Keplr browser extension. Check it by pasting this wallet address into finder.terra.money, with ‘Mainnet’ selected. If there is a balance, hooray! You have received your airdrop. You should be able to access them by adding “Terra 2.0” to your Keplr browser extension.

  1. Remove old Terra from Keplr if you haven’t yet, and re-add it with the button at the bottom left of wallet.keplr.app, to have it come up as Terra Classic (this also fixes the issue Keplr had with estimating gas fees on Terra Classic)
  2. Add Terra 2.0 by going to https://frontier.osmosis.zone/assets and clicking “Deposit” on Luna 2.0. Approve the Keplr pop-ups.

Your Keplr browser extension should then look like this with both Terra Classic and Terra 2.0.

Check Terra 2.0 to see if it has any balance. It may also be a different wallet address to your Terra Classic. You can check it on finder.terra.money for more details on your airdrop and vesting.

If you still don’t see any airdrop, the last thing to try is recovering your Keplr wallet in Terra Station wallet. This only works if your Keplr wallet has a seed phrase - not with a private key. Be careful with your seed phrase! Do not enter it anywhere outside of the legitimate Terra Station and Keplr apps, and run an antivirus scan first, to be sure your seed phrase can’t be leaked.

  1. Download Terra Station desktop: Download — Terra Docs documentation
  2. Click ‘Connect’ in the top right
  3. Choose ‘Recover wallet’
  4. Choose a name and password, and enter your seed phrase under ‘mnemonic’
  5. Confirm and select the 118 wallet (118=cosmos derivation path)

As you can see for this wallet, the airdrop has been found under the Cosmos wallet address!

If you have gone through all these steps, or do not have a seed phrase to test on Terra Station, please post below with the following details.

  1. Osmosis wallet address
  2. Terra wallet address(es)
  3. Did you have an LP on Osmosis, if so, which one?
  4. Or did you have individual Luna or UST coins on Osmosis, not in an LP?

With these details we can investigate further, and potentially fund missing airdrops by a community pool spend in the future.


Hi @rosanne89
Could you help me to find airdrop, all the above steps were not working for me, don’t have airdrop on my Kepl wallet which I created via email (gmail), so I don’t have seed phrase.

Here are my details:

  • Osmosis wallet address:

  • Terra wallet address(es)
    (I did transfer earlier to that address but Luna tokens were brought from CEX, not as airdrop)

  • Did you have an LP on Osmosis, if so, which one?
    I had UST/OSMO (there were around 70000 UST / and equivalent amount of OSMO)
    at the time of the second snapshot I had that LP unbounded and depooled but my 14 days timeout period finished the day after on 28th May

  • Or did you have individual Luna or UST coins on Osmosis, not in an LP?
    I believe I had a few Luna v1 and UST tokens but not much.

Thanks, I’ll add you to the spreadsheet. I see you got an airdrop of 1 luna vested, so that doesn’t look right for 70,000 UST!

Thanks, looking forward for your help.

  1. osmo1w2xthktpufpujzdt2uhkjw708sgzq7m4kupg73
  2. terra1w2xthktpufpujzdt2uhkjw708sgzq7m4crgc2r
  3. Yes: I had OSMO/UST pooled, and UST in my Osmosis assets.
  4. Didn’t have individual Luna, but I did have UST.

Never held LUNA before and never installed Terra Station. As you can see, there is no balance or transaction history on my Terra address.

Good to know: I use a Ledger hardware wallet. And of course never entered my seed phrase anywhere.

Couldn’t do the last method of this post here. However I did try adding my Ledger to the Terra Station browser extension, but that didn’t work either.

I tried every step of the Reddit posts (including the updated ones) and this post too. Unfortunately, it didn’t work.

Rumor has it that if you got <1 LUNA airdropped, you will not get any. But I had a couple thousands $ worth of OSMO/UST and UST, so it would be strange if that’s the case.

Thanks for your efforts! Really glad the team is picking this up and is taking this seriously.
Hope this issue will be resolved soon.

Thanks, that’s all very helpful info! I will add you to the spreadsheet.

Note to all - this doesn’t mean the airdrop will magically be fixed, but it is a start!

terra1ktcfyrqtanmherc8ss4w970dhdrndqf3khn766 (Terra Station Address)
terra1wguts9hzgx8ym0s8gv2x4fjhac4dgnxm42zmx4 (Terra 2.0 Addres on Keplr)
osmo1wguts9hzgx8ym0s8gv2x4fjhac4dgnxmm4ttj8 (Osmosis the address I’ve been holding UST for months)

I could not see any airdrop on either Keplr or Terra Station.

Do you have a recommendation? Thank you.

Also I am using ledger.

Hi, it looks like you transferred your UST to Binance before the snapshot (21 days ago). Is that correct? If you still had this UST on Binance on 27/5, you will get the airdrop there.

1 Like

True, but when I sent 5,000 UST, I had a total of 10,000 UST in my wallet. If you look carefully, there are 5,004 UST that have been in my wallet for a long time.




$ 0.00

$ 0.00

Got it, thanks. So you’re aware, the first snapshot didn’t include UST, only aUST (UST on Anchor protocol) but the second one on May 27 did include it. So I will add you to the spreadsheet for the team to look into further.

1 Like

Hi @rosanne89
Osmo address : osmo1z5wdx6anglnsj50e46ukcm4tf2095ppkg7c8pk
New Terra 2.0 address : terra1z5wdx6anglnsj50e46ukcm4tf2095ppkxp3h4y
Yes. I have OSMO/UST LP
I did not seperate luna or USt just unbonded UST after the depeg issue.

Thanks, good point about unbonding, maybe that has something to do with it. Will add to investigation!

1 Like
  1. Osmosis wallet address

  2. Terra wallet address(es)

  3. Did you have an LP on Osmosis, if so, which one?

  4. Or did you have individual Luna or UST coins on Osmosis, not in an LP?
    I have only LUNC on Osmosis

Hi, these LPs aren’t eligible for a Terra airdrop. Did you have Luna sitting in Osmosis for the pre-attack snapshot on May 7?

(I ask about the pre-attack snapshot because the post attack snapshot requires a balance over 70,000 or more Luna to get an airdrop)

  1. Osmosis Wallet Address: osmo1pr3a2lqme7zv6d7vja63hra5ax4qlsgzauqy3d
  2. Terra (Keplr) Wallet Address: terra1pr3a2lqme7zv6d7vja63hra5ax4qlsgznrf59l
  3. I have LP in UST/OSMO and LUNA/OSMO, they are both still bonded and the LP.
  4. I have LUNA still in my LUNA (Keplr) wallet.

I rarely used my LUNA Keplr wallet now that I checked my history using finder.terra.money. Most of my transactions into UST and LUNA came from conversions from CRO into OSMO, and from there I used the single LP option to put liquidity into the UST/OSMO and LUNA/OSMO. Could this lack of history on my LUNA Keplr wallet cause me to get missed on the snapshot?

1 Like

Hi, thanks for doing this.

Osmo address: osmo140l6y2gp3gxvay6qtn70re7z2s0gn57zyzq5sn
Terra address: terra140l6y2gp3gxvay6qtn70re7z2s0gn57z2afyyp
Yes, I had OSMO/UST LP - around 75k UST (and equivalent OSMO)
I did not have any separate amounts.

Thank you!

1 Like

Thanks all, I’ll come back to this tomorrow and add to the spreadsheet.

No, I don’t had a pre attack LUNA, I have 550k LUNC

Thanks for catching up with this issue!

I have a bag of UST coins until today, exited from UST/XPRT LP pool #612 5 days ago.

There might be two issues, one from Osmosis, and one probably from Terra.

I found UST is labeled as “UNKNOWN” on OSMOSIS. Today, I tried to put those UST coins into pool #560 (UST/OSMO). As you’d find its coin ID, it is "UNKNOWN’. txHash : F53604BF5CA58B639132A892A6A92B7408F576138BA916BDC5E5513A8F37EC9B

The other issue would be that there has been 0.014 LUNC on the Terra Classic (not in OSMOSIS) in my Keplr wallet. I checked out those wallets above, most of them also have less than 1 LUNC in their Terra wallets as well. When there were both lots of UST in OSMOSIS and <1 LUNC in Terra classic wallet, probably only Terra wallet could be considered?

I got 0 LUNA airdropped in my Terra (Keplr) wallet, the same address for Terra classic and Terra 2.0, terra1kjujs93lvmgqtsyq5lp2d8y295ukj2vt3j32wc